CDROM Icon Missing - Comments Page 1

Category: Hardware




(Read the article: CDROM Icon Missing)

All Comments on: "CDROM Icon Missing"

Comment Page: 1 |  2  |  3  |  4  |  5  |  6  |  7 

Posted by:

jimi
29 Jun 2006

Hi Bob, good article, and useful! I just want to point out one other culprit, one i personally dealt with: the Sony Rootkit that was a hot ticket a few months ago on the web, did exactly that to me! so....ya never know!!

Posted by:

wawadave
29 Jun 2006

I find in helping out at castlecops forum this come up many times! If the drive is showing in device manager. Than removing the drive from the device manager and rebooting works for quite a few cases.

Posted by:

Paul
30 Jun 2006

Not in my case it didnt. I had a machine at work today which had these very symptoms, even tried putting another cdrom in. Still no joy. After following the registry fix given on this site, it worked spot on! Great fix, thanks!

Posted by:

-=KEENO=-
10 Aug 2006

Registry entry worked perfect.

Mate had this excact same problem and spent days trying to nut it out, Thanks heaps!

Posted by:

Holvin
24 Aug 2006

I had the same problem but with different results after do this procedure. Now my CD Rom dont wants to read any type of CD. It's come stuck with message: Device not responding. What can be?

EDITOR'S NOTE: Have you tried the drive in another machine? Tried another drive in this machine?

Posted by:

Bart
24 Sep 2006

I use windows XP and 2000, my CD Rom is missing in windows XP while I can see it in CMOS settings. Its also not listed in device manager. I tried the registry tweek but there was only the "LowerFilters" entry, I deleted and rebooted my PC still no luck. My CD Rom works fine in windows 2000 installed in the same PC. Pls help.

EDITOR'S NOTE: It seems your XP install is damaged. You might want to try http://www.askbobrankin.com/missing_or_damaged_dll_files.html

Posted by:

Dan
27 Sep 2006

I have a DVD (master) and a CDROM (slave) installed on a machine running Win2K pro. About 3 weeks ago the CDROM quit working. I had both icons, device manager recognized both drives, the lights would blink on the drives, but I could not read any type of CD. I figured the CD must be dirty or have an electronics problem. I sprayed compressed air into the drive. Still didn't work. I then replaced the data cable. It still would not read a CD. About two days ago I noticed the DVD quit working. I figured this could possibly be a power supply problem or the onboard controller maybe going bad.

On bootup windows would recognize the drives, but I had no icons for the DVD or CD and the error given by device manager was : "A driver for this device was not required, and has been disabled. (Code 32) "

That didn't make a bit of sense to me so I removed the hardware in device manager and rebooted. Windows says it found new hardware and to reboot again for the change to take effect. After rebooting I still had no icons.

I was about to open the case and check the power supply cables to each drive and needed the pinout info. While researching that on the internet I discovered your site and tried your registry fix. What a blessing. Both drives now work. I was so desperate to keep from reinstalling windows and all my software that I would have settled for just one drive working.

I had been installing and uninstalling some programs lately and feel that was what caused this problem. Thanks for the registry fix info. It saved me a lot of work and frustration.

Posted by:

michael
07 Oct 2006

thanks i hack the system like u said and it brought it all back to normal

Posted by:

TechnoJock
23 Oct 2006

Hi ya, installed universial usb drive (nusb22e setup for windows 98SE)and this caused some sort of conflict with my in my secondary IDE controller- has yellow exclamation "code 10". My CD-rom/ DVD-rom icon in my computer have disappeared. Tried the safemode delete of all cd-rom dvd-rom refs in device manager and reboot to let windows redetect the devices. Unfortunately no joy. CD-ROM has disappeared from my devices but DVD-ROM is present but has a X over it, and same warning for secondary IDE. The icon is still absent for the drive (D: drive). I did remove all previous usb drives before nusb22e install, and I pretty sure it's the nusb22e drive that's done it. However, I can't remove nusb22e because I don't know where it put all the files and isn't in the add/remove program list. Any help at all would be welcome please. Oh nusb22e works fine as a universial...I just can't access my cd-rom/dvd-rom, bummer. Thanks

EDITOR'S NOTE: Did you try the registry trick mentioned in this article?

Posted by:

TechnoJock
24 Oct 2006

Hi, I looked in the registry but in the Windows 98 SE folder: 4D36E965-E325-11CE-BFC1-08002BE10318, there were three entries called CD-ROM. I didn't delete them because they were not the same as the entries in the example above. However after experimenting (disabling both primary and seconday IDEs via the master IDE, rebooting, and then re-enable both IDEs, then reboot). This redetects my CD-rom/DVD-rom drive and the drive icon reappears (ROM works fine). Unfortunately once the computer is rebooted the error message reappears and the drive icon goes missing and there is a cross on the ROM drive in device manager.

The above happens everytime and I end up with the original problem of no DVD/CD-ROM. If I delete the CD-ROM registry entry will that make any difference? Also is it possibly to uninstall CD-Rom driver and reinstall (might be corrupt, but not sure how to do it). Thank you for any help.

Posted by:

Kayce
04 Nov 2006

Hi. I have a similar problem where I get error 39 on my driver. I have tried your registry fix and this does get my d: working however it slows my machine down and I sometimes have trouble rebooting. When this happens I have to reboot using 'last good configuration' Any suggestions?

EDITOR'S NOTE: I can't see how this would slow down your computer. You must have other problems as well. See http://www.askbobrankin.com/make_windows_xp_run_faster.html for some additional help.

Posted by:

eshayaway
13 Nov 2006

The same thing happened to me. I finally worked it out how to fix the problem.Windows xp System Restore fixes the problem. Go to Start then Programs then Accessories then system tools then system restore.

Restore windows back to the day that your computer was working properly. good luck. It worked for me.

EDITOR'S NOTE: This may work, but it will also wipe out any other system changes you've made since the Restore date, as well as any software installed since then. See http://www.askbobrankin.com/system_restore.html

Posted by:

Mich
22 Nov 2006

Hello! I had a problem with my laptop DVD-RAM. For several weeks, Windows XP (as well as the BIOS) couldn't detect the drive. Yesterday, it suddenly appeared on my systems devices so immediately searched for ways to install the driver. Removing the device then reinstalling the drivers didn't work. But the registry modification did! I tested a data cd but I kept on getting a I/O device error.

According to a site (I forgot which), changing the settings of the IDE controller would solve it. I modified my Secondary IDE Channel, changing the Transfer mode of Device 0 to PIO Only worked. I was able to read the data CD.

Then I tested a DVD. The explorer stopped responding and the DVD-RAM is nowhere to be seen on the device manager. I inspected the event viewer and I got same message when the disk drive first disappeared. "The device %% disappeared from the system without first being prepared for removal".

Could it be that it's the IDE cables fault? I don't know how to take apart my disk drive. I have a Toshiba Satellite A10 model.

EDITOR'S NOTE: Weird stuff! Try swapping the IDE cable out. You might also want to check for damaged or missing system files. See http://www.askbobrankin.com/missing_or_damaged_dll_files.html

Posted by:

Daozeng
24 Nov 2006

Thanks for your great solution to solve my CDROM icon missing problem by removed the upper and lower filters in the register.

Posted by:

lee
26 Nov 2006

Excellent information! I was about to throw my pc out of the window in frustration until your registry hack solved all! I'd love to know what the hack actually does... Cheers!

Posted by:

ShiFu
03 Dec 2006

If you have Windows XP SP2 and the SONY DVD RW DW-U12A drive... If you get error 39, 38, 29, and/or 28, don't try this, you will have another set of keys in your registry.

Sony.com doesn't support most drivers for it, and doesn't keep updates for it either. The only way you can get the drvers is to pay $20, or illegaly download it. AND: If you got the sony rootkit (a virus) you'll have to un-install it, clean your regisrty, remove infected files, re-install it, and pay $20/download the drivers.

Posted by:

Nick
07 Dec 2006

Bob, thank you. This saved me. I have just one question for you...Why did it happen?

EDITOR'S NOTE: Evil Gnomes, most likely.

Posted by:

R Scott
08 Dec 2006

Thanks Bob after Microsoft, in so many words, said FThanks Bob after Microsoft, in so many words, said F

Posted by:

Line
13 Dec 2006

Registry fix worked like a charm. Thank you!!!

Posted by:

mike
16 Dec 2006

Registry fix worked for me to a point. The cds are recognized in safe mode but stalls with a normal boot. Help!

Comment Page: 1 |  2  |  3  |  4  |  5  |  6  |  7 

Read the article that everyone's commenting on.

To post a comment on "CDROM Icon Missing"
please return to that article.

Send this article to a friend. Jump to the Comments section. Buy Bob a Snickers. Or check out other articles in this category:





Need More Help? Try the AskBobRankin Updates Newsletter. It's Free!

Prev Article:
Buying a Computer
Send this article to a friend
The Top Twenty
Next Article:
Google SMS

Link to this article from your site or blog. Just copy and paste from this box:



Free Tech Support -- Ask Bob Rankin
Subscribe to AskBobRankin Updates: Free Newsletter


Privacy Policy     RSS/XML